/ Eclipse

临时解决 Eclipse 在 Arch Linux 下的显示问题

自从 Eclipse Mars 开始使用 GTK-3 作为默认后端,其显示问题层出不穷,比如显示不全、对话框完全黑屏、反应缓慢等问题。当然最影响使用的还是代码区域疯狂闪屏,这些问题 Arch Linux tracker 上也挂了好些年月了。所以根本的解决问题就是切换回 GTK-2(当然需要提前安装)

只需编辑 /usr/lib/eclipse/eclipse.ini

念两句诗:

--launcher.GTK_version
2

最终报导出来是这个样子(当然 Eclipse 的版本也是很重要的):

-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.500.v20170531-1133
-product
org.eclipse.epp.package.cpp.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.defaultAction
openFile
--launcher.GTK_version
2
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.8
[email protected]/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m

虽然 GUI 变得丑了一点,但也起码能用了不是?

临时解决 Eclipse 在 Arch Linux 下的显示问题
Share this

Subscribe to 伝説の町